Bug Thrive Ultimatum : liens qui ne fonctionnent pas

Bug Thrive Ultimatum : liens qui ne fonctionnent pas
0

(Joannie Therrien) #1

Salut à tous!

Je suis certaine que quelqu’un parmi vous pourra m’aider!

J’ai un problème avec les liens de tracking dans mes courriels pour ma campagne de vente de mon e-book.

En résumé, j’utilise thrive ultimatum pour donner un deadline aux gens qui veulent mon e-book en rabais. Apres 4 jours, ils sont redirigé vers la landing page avec le prix régulier. Ce qui est emmerdant c’est que pour que ça marche, j’envoie un lien personnalisé via mailchimp.

La forme est comme ceci :
https://joannietherrien.com/video-appareil-photo-rabais/?tu_id=2646&tu_em=|EMAIL|
et
https://joannietherrien.com/achat-livre-photo-rabais/?tu_id=2646&tu_em=|EMAIL|

Sauf que, quand certains utilisateurs cliquent dessus, il ne s’ouvre pas. Par contre, lorsque je leur envoie le lien comme il serait supposé être avec leur courriel, ça fonctionne.

Une abonnée m’a écrit ce matin que les liens ne fonctionnaient pas, peu importe le navigateur. Elle a reçu ce message :

An error occurred while processing your request.
Reference #97.3dfe043e.1547133459.9c23b675

Alors, ça pourrait être quoi? Des idées?


(Olivier Lambert) #2

Il y a sans doute une erreur dans ton lien personnalisé… Tu dis que ça marche lorsque tu créer le lien toi-même, mais pas quand c’est Mailchimp.

La première explication qui me vient en tête serait le click tracking Mailchimp!

Peux-tu copier coller un exemple de lien qui ne marche pas?


(Joannie Therrien) #3

Merci beaucoup Olivier de ta réponse.

En fait c’est que quand disons je clique moi même sur le lien dans le courriel auquel la personne m’a repondu que ça ne marchait pas, il s’ouvre dans chrome d’abord avec plein de lettres et chiffres, et ensuite il se met comme supposé, par lui-même, avec le email de la personne. Alors à ce moment là, je le copie colle, je l’evoie en réponse à la personne, et inevitablement, ca marche.

Dans le email, voici les deux lien, tel quel comme il est dans mailchimp
lien 1 (lead magnet): https://joannietherrien.com/video-appareil-photo-rabais/?tu_id=2646&tu_em=|EMAIL|
Lien 2 (pitch de vente): https://joannietherrien.com/achat-livre-photo-rabais/?tu_id=2646&tu_em=|EMAIL|

Dans les deux cas, quand je suis allée pour le copier et le mette ici, Mailchimp m’a dit Please enter a valid URL or merge field.
29

Pourtant, c’est exactement ça que Thrive Ultimatum me fournit comme lien, je l’ai carrément copié collé et j’ai mis du texte par dessus genre comme ça :

10

J’ai des gens pour qui ça marche, obviously, sinon je vendrais juste jamais mon livre à rabais. Mais, j’ai de plus en plus de monde qui se plaignent que ça marche pas. Fait chier.


(Joannie Therrien) #4

Autre information pertinente

Selon mon dashboard de Thrive Ultimatum, la campagne fonctionnait bien et avait une belle croissance jusqu’au 6 janvier, après la drop est intense. Semblerait que le problème a commencé là. À ce moment là, je faisait des tests pour créer une nouvelle campagne ultimatum pour mes consultations, sans le lockdown.
16

En faisant des recherches, le message d’erreur “An error occurred while processing your request.” aurait rapport avec le caching.

Je sais que T.U. nécessite que les pages sur lesquelles les campagnes s’appliquent doivent être exclues du caching pour que le lockdown fonctionne. Mais si le lockdown n’est pas activé sur une campagne, dois-je aussi les exclure du caching?


(Olivier Lambert) #5

Je n’ai jamais configuré Thrive Ultimatum alors c’est un peu tricky pour moi de trouver la source du problème.

Est-ce que tu es capable de reproduire l’erreur d’une façon ou d’une autre?

Pour ta cache, ajoutes un regex à la fin.

/achat-livre-photo-rabais.*

.* va matcher n’importe quoi, c’est pour s’assurer que la query string de l’adresse e-mail ne pose pas problème.


(Joannie Therrien) #6

Ouin, je comprends que c’est pas évident!

J’ai fait ce que tu m’as dit pour ma cache, avec toutes les pages affectées par ultimatum, lockdown ou pas.

Après ça, je me suis inscrite à ma propre infolettre avec mon adresse gmail que j’utilise jamais.

J’ai essayé de reproduire l’erreur à partir du site de gmail, sur Chrome, Safari et Microsoft Edge, sur l’ordinateur. Tout se passe comme supposé, sauf microsoft edge qui affiche une page blanche pendant environ 3 secondes, après quoi tout s’affiche normalement. J’aurais tendance à croire que les gens sont pas patients et qu’ils abandonnent après 0.5 seconde. J’ai essayé de copier l’adresse du lien et de le coller dans la barre d’adresse. À ce moment là, la page se load normalement.

Sur mon iphone, j’ai été sur le site de Gmail et j’ai cliqué sur mon lien. Safari ouvre la page comme supposé.


(Olivier Lambert) #7

Je viens de m’inscrire, je vais tester de mon côté aussi!


(Joannie Therrien) #8

Finalement j’ai enlevé le lockdown pour le moment pour être sure… donc ça va marcher assurément. J’ai déjà perdu beaucoup de vente en une semaine à cause de ce bug alors j’ai préféré mettre un countdown evergreen normal qui ne barre pas les gens à la fin de la promo.
Si je veux approfondir les tests, je dois désactiver la campagne sans le lockdown et réactiver celle qui l’a, et risquer de perdre du monde si le bug revient.
Selon toi, est-ce que ça vaut vraiment la peine d’investiguer pour être capable de faire fonctionner le lockdown?
En jasant avec Joe, on se disait que ce serait plus simple sans le lockdown pour faire une petite campagne de remarketing, et je trouve qu’il a pas tort. Sinon si je remarket, je dois créer une seconde campagne ultimatum avec disons une extension rabais 24h ou peu importe et ça gosse un peu.


(Olivier Lambert) #9

Duplique le tout… Créer une nouvelle landing page avec un nouveau truc evergreen pour qu’on puisse continuer les test.

Ce genre de campagne convertit beaucoup trop bien pour ne pas se donner la peine de trouver la solution :slight_smile:


(Joannie Therrien) #10

Ok! Dupliquer les landing page ne me stresse pas trop. C’est plus au niveau des courriels. Si j’envoie les courriels avec des liens qui marchent pas, les gens embarquent juste pas dans le funnel du tout parce qu’ils recoivent la vidéo par e-mail et ensuite le countdown part quand ils vont voir la vidéo.
Si je veux prendre moins de monde en cas de bug monumental, est-ce que je peux faire un split test dans mailchimp que la moitié des gens recoivent les liens trackés et l’autre moitié recoivent le lien qui marche pour sur?